• Страница 1 из 1
  • 1
Модератор форума: Dimitro  
Форум » TrinityCore » [TrinityCore] Help » Ubuntu 14.04 (Не понимание ошибки)
Ubuntu 14.04
Spooka
Скаут
Всем доброго времени суток.
Моя история начинается с того что я приобрел VDS хостинг Ubuntu 14.04. И тут началось веселье... Вроде бы как делал все правильно но успехом это не обвенчалось. Кратенький изложу в чем суть и что я сделал .

Обновил операционную систему и установленные пакеты:

Код
apt-get update && apt-get upgrade


Установил дополнительные средства разработки (development tools):

Код
sudo apt-get install build-essential autoconf libtool gcc g++ make cmake git-core patch wget links zip unzip

Установка второго пакета средств разработки:

Код
sudo apt-get install openssl libssl-dev mysql-server mysql-client libmysqlclient15-dev libmysql++-dev libreadline6-dev zlib1g-dev libbz2-dev libncurses5-dev


Еще:

Код
sudo apt-get install libboost-dev libboost-thread-dev libboost-system-dev
sudo apt-get install libboost-program-options-dev

Установил ACE:

Код
1)wget http://download.dre.vanderbilt.edu/previous_versions/ACE-6.0.3.tar.gz
2) tar xvzf ACE-6.0.3.tar.gz
3) cd ACE_wrappers/
4) mkdir build
5) cd build
6) ../configure --disable-ssl
7) Make
8) sudo make install


После чего мы в прицепе уже загружаем Trinity Core на сервер. И вроде бы все должно быть хорошо. Я установил исходник.

Код
1. cd /home
2. git clone [url=https://github.com/TrinityCore/TrinityCore.git]https://github.com/TrinityCore/TrinityCore.git
3. cd TrinityCore
4. git checkout 3.3.5


Заходим в папку Trinity Core:

Код
cd Trinitycore
mkdir build
cd build


Производим конфигурирование для дальнейшего компилирования:

Код
cmake ../ -DPREFIX=/home/`echo $USER`/server


И тут как говориться понеслось :
1) Первое с чем я столкнулся это то что Сmake было не той версии то есть мне нужна была версия 3.2.х а у меня была 2.8 и чего то там, с этим я справился спустя долгие поиски решения данной задачи. Решил я ее таким образом :


Код
sudo apt-get install build-essential
wget http://www.cmake.org/files/v3.2/cmake-3.2.2.tar.gz
tar xf cmake-3.2.2.tar.gz
cd cmake-3.2.2
./configure
make


Все наконец то что то получилось. Но не тут то было, рановато я начался свою радость. Во время комплектации начало вылезать море каких то либо ошибок. Я роюсь уже 5 день в нашем любимом ГУГЛЕ но нечего найти так и не смог найти. Прошу вас добрые люди помочь мне в данной задаче. Если кому то не трудно конечно.

И огромная просьба к "Умным-программистам" Которые напишут по типу:  "Плохо видешь свои поиски" , "Это все фигня просто ты тупой (криворукий) " нууу и тому подобное. Просто воздержитесь от тупой писанины.
Сообщение # 1 отредактировано Spooka - Суббота, 27.01.2018, 19:22
Infernales
Капрал
Во-первых зачем ACE? Его давно уже выпилили. Во-вторых где ошибки или мы сами должны их угадать? В-третьих официальную документацию читать пробовали?
Сообщение # 2 написано 27.01.2018 в 22:37
Spooka
Скаут
Цитата Infernales ()
Во-первых зачем ACE? Его давно уже выпилили. Во-вторых где ошибки или мы сами должны их угадать? В-третьих официальную документацию читать пробовали?
1) Пробовал. Там указано на Ubuntu 17.04. Ниже уже не идет. 
2) Извините пожалуйста что забыл приложить ошибки.)

А вот и ошибочка.

-- Detected 64-bit platform
-- UNIX: Using default configuration directory
-- UNIX: Using default library directory
-- UNIX: Configuring uninstall target
-- UNIX: Created uninstall target
-- UNIX: Detected compiler: /usr/bin/cc
-- cotire 1.7.10 loaded.
-- Using mysql-config: /usr/bin/mysql_config
-- Found MySQL library: /usr/lib/x86_64-linux-gnu/libmysqlclient_r.so
-- Found MySQL headers: /usr/include/mysql
-- Found MySQL executable: /usr/bin/mysql
-- Found git binary : /usr/bin/git

* TrinityCore revision   : 4130647bf6bb 2018-01-27 16:20:41 +0100 (3.3.5 branch)
* TrinityCore buildtype  : RelWithDebInfo

* Install core to        : /usr/local
* Install libraries to   : /usr/local/lib
* Install configs to     : /usr/local/etc

* Build world/auth       : Yes (default)
* Build with scripts     : Yes (static)
* Build map/vmap tools   : Yes (default)
* Build core w/PCH       : Yes (default)
* Build scripts w/PCH    : Yes (default)
* Show compile-warnings  : No  (default)
* Use coreside debug     : No  (default)
* Show source tree       : Yes (hierarchical)
* Use GIT revision hash  : Yes (default)

CMake Error at cmake/macros/FindBoost.cmake:1231 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.54.0

  Boost include path: /usr/include

  Detected version of Boost is too old.  Requested version was 1.55 (or
  newer).
Call Stack (most recent call first):
  dep/boost/CMakeLists.txt:44 (find_package)

CMake Error at /usr/local/share/cmake-3.2/Modules/FindPackageHandleStandardArgs.cmake:138 (message):
  Could NOT find ZLIB (missing: ZLIB_LIBRARY) (found version "1.2.8")
Call Stack (most recent call first):
  /usr/local/share/cmake-3.2/Modules/FindPackageHandleStandardArgs.cmake:374 (_FPHSA_FAILURE_MESSAGE)
  /usr/local/share/cmake-3.2/Modules/FindZLIB.cmake:110 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  dep/zlib/CMakeLists.txt:13 (find_package)

-- Configuring incomplete, errors occurred!
See also "/home/TrinityCore/build/CMakeFiles/CMakeOutput.log".
See also "/home/TrinityCore/build/CMakeFiles/CMakeError.log".
Сообщение # 3 написано 27.01.2018 в 22:45
Infernales
Капрал
Цитата Spooka ()
Пробовал. Там указано на Ubuntu 17.04. Ниже уже не идет.

Цитата Spooka ()
Detected version of Boost is too old. Requested version was 1.55 (or newer).

Цитата Spooka ()
Could NOT find ZLIB (missing: ZLIB_LIBRARY) (found version "1.2.8")

У тебя два варианта:
1. Обновляй ОС.
2. Собирай пакеты требуемых версий.
Сообщение # 4 написано 27.01.2018 в 22:50
Spooka
Скаут
Цитата Infernales ()
У тебя два варианта:
1. Обновляй ОС.
2. Собирай пакеты требуемых версий.


Попробую обновить)
Сообщение # 5 написано 27.01.2018 в 22:52
Форум » TrinityCore » [TrinityCore] Help » Ubuntu 14.04 (Не понимание ошибки)
  • Страница 1 из 1
  • 1
Поиск: