• Страница 1 из 1
  • 1
Модератор форума: Dimitro  
Форум » TrinityCore » [TrinityCore] Help » Проблема с компиляцией Debian (oregon core)
Проблема с компиляцией Debian
walerik11
Чемпион
начинаю компиляцию выдает ошибку 
Код
[ 5%] Built target gsoap 
config.status: error: cannot find input file: `[url=https://vk.com/away.php?to=http%3A%2F%2Fconfig.stamp.in&cc_key=]config.stamp.in' 
dep/jemalloc/CMakeFiles/jemalloc_internals.dir/build.make:51: recipe for target 'dep/jemalloc/jemallocs_internals' failed 
make[2]: *** [dep/jemalloc/jemallocs_internals] Error 1 
CMakeFiles/Makefile2:163: recipe for target 'dep/jemalloc/CMakeFiles/jemalloc_internals.dir/all' failed 
make[1]: *** [dep/jemalloc/CMakeFiles/jemalloc_internals.dir/all] Error 2 
Linking CXX static library libshared.a 
[ 5%] Built target shared 
Makefile:117: recipe for target 'all' failed 
make: ***  [all]Error 2Код
У меня ревизия старая поменял папку CMakefiles от новой ревизии получил другую ошибку
 
Код
5%] [ 5%] Building CXX object src/shared/CMakeFiles/shared.dir/Log.cpp.o 
Building CXX object dep/gsoap/CMakeFiles/gsoap.dir/soapServer.cpp.o 
/opt/server/wowbc/s/src/shared/Util.cpp: In function ‘bool Utf8toWStr(const char*, size_t, wchar_t*, size_t&)’: 
/opt/server/wowbc/s/src/shared/Util.cpp:287:18: warning: deprecated conversion from string constant to ‘wchar_t*’ [-Wwrite-strings] 
wstr = L""; 

/opt/server/wowbc/s/src/shared/Util.cpp:298:14: warning: deprecated conversion from string constant to ‘wchar_t*’ [-Wwrite-strings] 
wstr = L""; 

Linking CXX static library libshared.a 
[ 5%] Built target shared 
Linking CXX static library libgsoap.a 
[ 5%] Built target gsoap 
Makefile:117: recipe for target 'all' failed 
make: ***  [all]Error 2
 В линукс не силен поэтому такой вопрос?
Сообщение # 1 написано 17.01.2018 в 17:41
Infernales
Капрал
Ну смотри, ты пытаешься собрать старую ревизию TrinityCore, но при этом скорее всего используешь новый софт, который естественно не подходит для сборки.
Тут есть два варианта решения:
1. Обновляйся до последней ревизии TrinityCore.
2. Делай даунгрейд пакетов, а возможно и всей системы.
Сообщение # 2 написано 17.01.2018 в 17:58
walerik11
Чемпион
Infernales, спасибо жаль что ни чего не сделать( буду обновляться на последнюю реву тогда)
Сообщение # 3 написано 17.01.2018 в 18:20
Aksim
Скаут
Поскольку в линуксах я так же полный валенок, то спрошу в этой же теме интересующую меня вещь)
Если я скомпилю сборку на  ubuntu, то смогу ли потом перенести ее на другой комп и запустить на debian?
Сообщение # 4 написано 21.01.2018 в 20:04
Infernales
Капрал
Да хоть на Gentoo, если не будет использовано специфических параметров при компиляции, а так же будут совпадать версии требуемых пакетов. Возможно будет можно обойтись приложением требуемых библиотек.
Сообщение # 5 написано 21.01.2018 в 22:17
Aksim
Скаут
Специфические параметры это конечно врятли. Ох уж эти линуксы....совпадать версии требуемых пакетов.
Я конечно понимаю что Бил Гейтс козел и видовсмастдай, но как же все просто в этом виндовсе и заковыристо в линухе
Сообщение # 6 написано 21.01.2018 в 23:37
Infernales
Капрал
В Windows абсолютно тоже самое, так что тут не эти уж "линуксы" виноваты.
Сообщение # 7 написано 21.01.2018 в 23:40
Форум » TrinityCore » [TrinityCore] Help » Проблема с компиляцией Debian (oregon core)
  • Страница 1 из 1
  • 1
Поиск: