• Страница 1 из 1
  • 1
Модератор форума: Dimitro  
Форум » TrinityCore » Установка / Настройка TrinityCore » Ошибка OpenSSL при компиляции (OpenSSL выдаёт ошибку)
Ошибка OpenSSL при компиляции
sollosollo4
Скаут

Какие только я уже версии не пытался установить OpenSSL, все равно выдаёт ошибку
Если устанавливаю свежую, выдаёт ошибку, что TrinityCore нуждается в версии 1.0
Устанавливаю OpenSSL 1.0, выдаёт то, что вы видите на скрине
Помогите плиз, я пока не очень силён, очень много где копался, на английских форумах мало, что про это написано, а на гитхабе и оф. сайте в поддержке и гайдах ничего об таком не сказано ( https://trinitycore.atlassian.net/wiki/display/tc/ - здесь тоже нет )

CMake Error at cmake/macros/FindOpenSSL.cmake:191 (file):
file STRINGS file "C:/OpenSSL/include/openssl/opensslv.h" cannot be read.
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)

CMake Error at cmake/macros/FindOpenSSL.cmake:203 (list):
list GET given empty list
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)

CMake Error at cmake/macros/FindOpenSSL.cmake:204 (list):
list GET given empty list
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)

CMake Error at cmake/macros/FindOpenSSL.cmake:205 (list):
list GET given empty list
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)

CMake Error at cmake/macros/FindOpenSSL.cmake:206 (list):
list GET given empty list
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)

CMake Error at cmake/macros/EnsureVersion.cmake:76 (MATH):
math cannot parse the expression: "..`*10000 + ..`*100 + 0": syntax error,
unexpected exp_TIMES, expecting exp_PLUS or exp_MINUS or exp_OPENPARENT or
exp_NUMBER (4)
Call Stack (most recent call first):
cmake/macros/EnsureVersion.cmake:111 (NORMALIZE_VERSION)
cmake/macros/FindOpenSSL.cmake:224 (ENSURE_VERSION_RANGE)
dep/openssl/CMakeLists.txt:16 (find_package)

CMake Error at cmake/macros/FindOpenSSL.cmake:226 (message):
TrinityCore needs OpenSSL version 1.0 but found version ..`
Call Stack (most recent call first):
dep/openssl/CMakeLists.txt:16 (find_package)
_______________________
Решено - Установил версию OpenSSL 1.0.2k (при компиляции в c++ 15 ошибок:))
C++ это не сложно. До классов elun'ы...
Сообщение # 1 отредактировано sollosollo4 - Четверг, 09.03.2017, 23:23
Форум » TrinityCore » Установка / Настройка TrinityCore » Ошибка OpenSSL при компиляции (OpenSSL выдаёт ошибку)
  • Страница 1 из 1
  • 1
Поиск: